Get in touch
Back
Maintenance

Planned maintenance

Completed 6 Jan at 05:15pm GMT.

Management Dashboard User Authentication Device Data Submission
Completed

Maintenance completed

Posted 6 Jan at 05:15pm GMT.
Started

We are performing improvements to our infrastructure and will be back up soon.

Posted 6 Jan at 04:16pm GMT.